Back to overview
Downtime
Tbh.athlens.co is unavailable
Apr 07 at 04:32pm EDT
Resolved
Apr 07 at 04:36pm EDT
Done
Affected services
Updated
Apr 07 at 04:35pm EDT
We’re back! TBH should be up and running for most users. Thanks for bearing with us.
Affected services
Created
Apr 07 at 04:32pm EDT
We’re investigating an issue with TBH that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services